Jog5000

Rear Sunblind - what's up??

Recommended Posts

Hi all.

I'm new to Jaguar and to this forum. I've just picked up a 2003 3.0 S-Type, in decent shape.

Only problem, the rear sun blind doesn't work. When I push the button, nothing happens, no motor noise, no movement. I've asked on a few other forums and all anyone can come up with is give it a good pull while pushing the button. Tried that, doesn't work.

I'm not sure what fuse number it is either,I've seen 21, 26, 18... Can anyone fill me in on that, and any other suggestions?

Thanks all.

Share this post


Link to post
Share on other sites

Welcome to the club, Daniel.

 

My s type does not have a sun blind, so I suggest you follow Trevor's link

 

Regards,

 

Peter.

Share this post


Link to post
Share on other sites

Nope, same model, no sun blind. The range of optional extras must have been quite staggering. I wonder how much a 3.0L S Type Sport would have been with all the optional extras added in 2003, and does such a beast exist I wonder?

Share this post


Link to post
Share on other sites

Yes, Kevin, the optional extras on all Jaguar Models was quite extensive.

 

On my SE I don't have the optional TV, or the optional Jaguar Voice, and I believe the Alpine Stereo system was an extra, too, which I haven't got either. I don't have [and wouldn't have chosen one] a sunroof.  The touch screen system is fitted on my SE, but I think it cost about £2k as an option.  18" wheels were an extra few bob, too.

 

I think that there was about a £20k difference in price if you had all the options. 

Share this post


Link to post
Share on other sites

Hi all.

 

Thanks for the replies. I think, because its the Middle East where I'm at, the sun-blind came as standard issue. It's more of an irritation that I have something on my car not working....

Share this post


Link to post
Share on other sites

There is a section in my handbook telling me how to use it!

 

Peter.

Share this post


Link to post
Share on other sites

My handbook is completely in Arabic, I cant read Arabic! 

 

The ones I've read online say push the button. When I push the button, nothing happens...

Share this post


Link to post
Share on other sites

Push the button is what it says in my handbook.

 

I can only think it must be the fuse or the switch itself.

 

Peter.

Share this post


Link to post
Share on other sites

The light in the switch turns on when I turn on the lights, and as for the fuse, I've been trying to figure out which fuse it is, but I've had a number of different options thrown at me.

 

As for reading the electrical guide, I cant find any fuse numbers in the circuit diagram.

Share this post


Link to post
Share on other sites

Hi Daniel,

 

I have found a Fuse location from a USA handbook which might be what you are looking for.

 

The fuse in question covers 2 electrical devices:

 

1. Power Folding Mirrors

2. Sunblind.

 

It is the Passenger compartment fusebox and its number is

 

F21 Mini 10a Red.

 

Goo luck.

 

Peter.

Share this post


Link to post
Share on other sites

Daniel,

 

I've found  " 21  mini red  sunblind " , don't know if it's correct or not, but won't hurt to try , think it's 10 amp.

 

ATB,

 

Trevor

Share this post


Link to post
Share on other sites

Thanks guys. I also got fuse 21, as well as fuse 26 as an option. Neither of them do anything. When I pulled fuse 21, (no electric mirrors fitted), and refitted it, I got a beep from the center console. Nothing else... Fuse 26, same story, nothing happening.

 

Are there no connections in the boot (trunk)?

Share this post


Link to post
Share on other sites

I thought that electric mirrors were standard on the S type, Daniel.

 

Just press the button underneath the mirror adjustment dial and the mirrors should fold in.

 

Peter.

Share this post


Link to post
Share on other sites

Lol, I dont have a button under the dial. Under the dial is the windows switches, no button for folding mirrors.

 

I've just been down to my car now, pulled both fuses, 21 and 26. Fuses are all intact....no rear blind. Going to try get into the parcel shelf on my next day off to check the blind...

Share this post


Link to post
Share on other sites

Lol, I dont have a button under the dial. Under the dial is the windows switches, no button for folding mirrors.

 

I've just been down to my car now, pulled both fuses, 21 and 26. Fuses are all intact....no rear blind. Going to try get into the parcel shelf on my next day off to check the blind...

Hi Daniel,on mine you just press on the bottom of the round mirror adjustment dial and release,they should fold,then press again and release to reset them.

With regards the rear blind i have found if they are not used they stick,with no sound from the motor at all.I gave mine a helping hand a 'tug',sprayed in some wd40 on the linkage and has been fine since,this is how i done it but maybe different for you.

Graham

Share this post


Link to post
Share on other sites

I'll give the mirrors a bash as soon as I'm done with work... As for the tugging, I'll give it another go too, and let you know. Thanks for the advice...

Share this post


Link to post
Share on other sites

I thought that electric mirrors were standard on the S type, Daniel.

 

Just press the button underneath the mirror adjustment dial and the mirrors should fold in.

 

Peter.

Hi all, I have electric adjustment on my wing mirrors but no 'fold in' option.

Share this post


Link to post
Share on other sites

Hi all, I have electric adjustment on my wing mirrors but no 'fold in' option.

Hi Kevin,

 

The specification for the 2003 3 litre S Type does indicate that it has foldable wing mirrors.  The dial that adjusts the morrors also folds in the mirrors.  Just press and release the lower part of the dial and they should fold in.  Similarly press and release to return them.

 

Peter.

Share this post


Link to post
Share on other sites

Hi Kevin,

 

The specification for the 2003 3 litre S Type does indicate that it has foldable wing mirrors.  The dial that adjusts the morrors also folds in the mirrors.  Just press and release the lower part of the dial and they should fold in.  Similarly press and release to return them.

 

Peter.

Cheers Peter, I'll give it a go at home time. (hope I don't get told off for talking off post topic again).

Share this post


Link to post
Share on other sites

Well, I did try the press and release etc... no folding mirrors. No motor sounds. I managed to fold them back by hand, with little resistance...

 

This is my VIN, if means anything to anyone: SAJAA02A43JM80597.

Share this post


Link to post
Share on other sites

Cheers Peter, I'll give it a go at home time. (hope I don't get told off for talking off post topic again).

Some posts do get well away from the topic  --  I put my hands up to being guilty on occasion  --  and I hope that members feel that my odd gentle reminder is basically tidying up discussions.

 

Last week however I did have to delete 17 very long posts from a new member, all put on immediately after he joined. I also had to give him what is known in these parts as the "Gypsies Warning."

 

Peter.

Share this post


Link to post
Share on other sites

Well, I did try the press and release etc... no folding mirrors. No motor sounds. I managed to fold them back by hand, with little resistance...

 

This is my VIN, if means anything to anyone: SAJAA02A43JM80597.

Hi Daniel,

 

The same fuse is used for both operations  --  so that could be the answer.

 

Otherwise I am mystified.

 

Peter.

Share this post


Link to post
Share on other sites

Well, I did try the press and release etc... no folding mirrors. No motor sounds. I managed to fold them back by hand, with little resistance...

 

This is my VIN, if means anything to anyone: SAJAA02A43JM80597.

Just a thought,under the round adjustment switch is the switch to alter the left or right mirror,this needs to be in the centre,just a thought you may have done this already.

maybe you could unclip the back of the wing mirror and have a look to see if its seized,as i remember i could push mine in manually but needed to spray the mechanism for it to function.

Good Luck.

Graham

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...