Jump to content


XF Reversing Camera - Intermittent Fault


TeeMc
 Share

Recommended Posts

Hi. I had today the same issue. Instead of running around and calling to places and wasting my time with overpriced Jaguar dealers. You people need to do one simple thing. Remove the car battery wires for a minute and then put it back and problem is solved.  With removing the battery ,the car restarts itself and repairs issue on its own.

Link to comment
Share on other sites

  • 5 months later...

I bought 2012 XF 3.0 Super charged about 14 months ago. For the first time, I noted that the reverse camera problem last night, after a long drive. There was no error message or anything. But the other functions of the screen work fine. The reverse and parking sensors worked, but the screen went blank during reversing! It seems this is a common problem. I will check again later to see if it works again. Thanks for all the posts! They were helpful.

Link to comment
Share on other sites

  • 3 weeks later...

I have this issue on a 2017 3.0s, normally when I most need the camera - reversing up to hitch the caravan or something like that. Has anyone found a fix yet - I suspect is just poorly written software.

Link to comment
Share on other sites

  • 1 month later...

The rear camera did not work for about three weeks but it came back on. I cancelled the appointment but the camera failed again. Another appointment was made as I knew the camera cable would be found to be broken. I informed the employer at the time of  the appointment, who took my details of . He advised my that the car would have a free "health check". This completed and he confirmed that I was correct. I had to pay £94.00 which I understood would be payment towards the full cost. Some £350.00 on top of the £94.00, as a new loom cable would be needed. Price £75.00 (total price £440.00).

I was lucky that I know some one who is an Electrician. The problem was fixed with a few connectors within 35. minutes. 

 

Link to comment
Share on other sites

So did anyone try the battery disconnect method as described at the top of this page? My 2013 Sportbrake has the annoying camera unavailable message with the  subsequent loss of all parking sensors. Ive also been quoted £180 for Jaguar diagnostics which may not find the problem. 

Im suspecting a relay of some sort is not latching properly as it is very intermittent and appears to work fine in dry/warm weather but as soon as the rain and frost comes..... beeeeeeeeeeep! How frustrating.

Link to comment
Share on other sites

  • 4 months later...

I have been suffering same intermittent) camera issue together with sensors not working, however if boot is opened and closed, issue sometimes goes away - and vice versa, commences. All points to the boot loom issue, however have just bought and fitted new one from JLR, same problem! Any other ideas (I think the broken loom in front bumper seems too obscure?). I have left boot lid liner off for now to facilitate any testing which may be required. 

Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...

I have a 2012 xf 3ltr d with intermittent fault on reversing camera and both rear indicators, all works fine then camera turns of and displays fault same with indicators can be left or right never both at same time. Any help would be appreciated.

Thank you 

Martin.

Link to comment
Share on other sites

  • 2 weeks later...

I HAVE THE SAME ISSUE ISSUE WITH MINE A 2012 XF 3.0 DIESEL .THE CAMERA WILL WORK THEN ALL OF A SUDDEN THE SENSORS AND CAMERA WOULD GO OUT.THIS HAPPENED AT BEGINNING OF YEAR FIRST THEN WHEN THE DRY WARMER WEATHER CAME IT WAS OK .NOW WE ARE BACK TO THE COLD DAMP WEATHER THE SAME HAPPENS AGAIN.

 HAVE HAD A SIMILAR PROBLEM ON MY BMW PREVIOUSLY AND WAS WONDERING IF IT WAS A SIMILAR ISSUE..I FOUND THAT TO BE A BROKEN WIRE IN THE GAITOR GOING FROM BOOTLID TO CAR BODY.

WHEN WE GET SOME DRY WEATHER I WILL LOOK.

Link to comment
Share on other sites

  • 1 year later...

The rear camera stopped working and Jaguar don't make a single part to fix the issue so they said have to replace whole wiring loom in the car which is approximately 3 months to manufacture and approximately £ 4000 and £ 2000 labour, all for a camera , unbelievable 

Link to comment
Share on other sites

1 hour ago, Jat said:

The rear camera stopped working and jaguar don't make a single part to fix the issue so they said have to replace whole wiring loom in the car which is approximately 3 months to manufacture and approximately £ 4000 and £ 2000 labour, all for a camera , unbelievable 

Not overly surprised at Jaguar .

Good luck with sorting the problem. Regards,  John

  • Like 1
Link to comment
Share on other sites

On my 2013 XF sportbrake the problem was faulty front bumper wiring loom (front offside parking sensor connection corroded) replaced for less than £200 by Jaguar dealer. On the XF the parking sensors and camera work as a complete system so a fault in any part can shut down all of it, eg a faulty front parking sensor can stop the rear camera working as well as the parking warnings.

If it was me I would be trying a good auto-electrician as they should be able to repair the wiring loom or even replace it with a used one for a fraction of that price. I would only expect that sort of cost for replacement of the entire wiring for the car. I know it is apples and oranges but I had the entire front wiring loom replaced on a Peugeot 208 by main dealer for £1200 4 years ago.

Good luck

  • Like 1
Link to comment
Share on other sites

3 hours ago, Big John said:

On my 2013 XF sportbrake the problem was faulty front bumper wiring loom (front offside parking sensor connection corroded) replaced for less than £200 by Jaguar dealer. On the XF the parking sensors and camera work as a complete system so a fault in any part can shut down all of it, eg a faulty front parking sensor can stop the rear camera working as well as the parking warnings.

If it was me I would be trying a good auto-electrician as they should be able to repair the wiring loom or even replace it with a used one for a fraction of that price. I would only expect that sort of cost for replacement of the entire wiring for the car. I know it is apples and oranges but I had the entire front wiring loom replaced on a Peugeot 208 by main dealer for £1200 4 years ago.

Good luck

Welcome to the exciting ownership of Jaguar !!!!!!!!!

Best Wishes, John

  • Like 1
Link to comment
Share on other sites

  • 7 months later...

Bought a year old ex-demonstrator Xfrs in Jan 2017. No issues with cameras until this year and discovered this topic page while seeking information. Camera failure was regular but random and warning signs came up when mobile not just when selecting reverse. For example would get a warning whilst driving that road signs were not readable but, after a lot of problems, I am convinced that the big coincidence was the weather. Car is not garaged and was subject to extremely high temperatures on front or rear during the summer. Cooling the car either using air-con to screen when driving or sheltering it when parked used to right the problem every time. Once the temperature dropped to “normal” levels all was ok and there has been not been a hint of repetition since we lost the ambient 38/39°. Regards. Roger R

  • Confused 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share





×
×
  • Create New...



Forums


News


Membership