Jump to content

parking sensors on my 2008 x type playing up yet again


Recommended Posts

my parking sensors were not working, so i had 2 rear sensors changed  "2 brand new ones from jaguar" and everything was fine for about a week & now they'v stopped working again, all sensors seem to be making the ticking noise when you put your ear by them, but when i select reverse gear im still getting the long loud 3 second beep to say, there's a fault on the system? im baffled by it now, any ideas please ?

Link to post
Share on other sites

Welcome to the club, Kevin.

 

Two questions that you may have answers to already.

 

Are the sensors nice and clean?  Are all the connections to the module clean and connected properly?

 

Other than that, the module could be acting up.

 

Regards,

 

Peter.

Link to post
Share on other sites
  • 2 weeks later...

here we go again, more problems on the x type.. the passenger power fold mirror motor has expired on me, i know thers's 2 motors.. 1 motor to move the mirror glass itself, jag charge £54 for this & 1 that actually folds the wing mirror body into the car door & the cheapest iv been quoted is £190 + v.a.t. looks like il be going on e.bay for a 2nd hand one to strip down for the motor.

2nd thing the car lost power the other day and the glow plug light was flashing on & off so i pulled over switched off & re started the car & everything was fine again, 2 weeks later & the same thing has happened again, this is with the special d.p.f. filter additive iv added to the fuel tank & i use redex every other tank full & thrash the daylights out of it on a regular basis to give it a good clear out etc!

what i am considering is having the d.p.f. filter removed professionally because they seem to be a pain in the butt.

So after 8 months of ownership i aint to impressed with the car at the moment, bearing in mind my car before this was a nissan 350z g.t 2006 model, that i never put a spanner on..

Link to post
Share on other sites

Hi Kevin,

 

I have never been sure about Redex -- don't know why.

 

Even though my car is running very well, I am booking it in foe a Terraclean next month.  I have been told that it certainly does give the engine a very good decarbonisation.

 

Peter.

  • Like 1
Link to post
Share on other sites

im gonna try some archoil 600 as well, spoke to a few mechanics & read up on the product write ups & reviews etc! it helps clean injectors, d.p.f. filter etc!

iv always put it in previous diesel cars iv owned in the past & they seem to run smoother on it, unless thats just me ?

the terraclean sounds good, let me know how the car runs after it its done, i might consider it for mine.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...



Forums


News


Membership