Jump to content


looking for help on this one


johnkarl
 Share

Recommended Posts

I have recently purchased an 03 x type 2.5 petrol and it has two problems, one i really need help with, All the brakes are binding on even when cold, the hotter they get the more they bind on, to the point that the car wont move, I have tried disconnecting the servo pipe, this made no difference, but i have noticed today that the brake lights are on permanently, and if i hook my foot under the brake pedal and pull it up, not only do the brake lights go out but the brakes release, is there an adjusting rod or is there something else i should be looking for, any help would be greatly accepted, cheers in advance

 

Link to comment
Share on other sites


Hi John --Is the pedal hard to pull up or easy and does it drop down again or stay up .???

Because if its stiff I would say a drop of WD40 is the answer fist to see if its just the pedal thats tight.???

Frank

Link to comment
Share on other sites

The pedal is very hard to pull up and it only comes up a couple of millimeters, it is also very hard to push down, feels almost solid, all 4 brakes are sticking on until i pull the pedal up, then the brake lights go out and the brakes come off, its looking like a master cylinder to me !!!!

Link to comment
Share on other sites

15 hours ago, johnkarl said:

All the brakes are binding on even when cold, the hotter they get the more they bind

Hi John

Just trying to be helpful, but the first thing I would say, is do not drive the car! you initial post seems to suggests you are, unless you have her up on stands, if so my apologies

if you are driving, I would strongly advise you get her off the road, until you or someone has sorted the problem

Regards

Steve

Link to comment
Share on other sites


Thanks for your response people, and cheers for the warning, but it is off the road. The only reason i know about all the brakes getting hot is because i drove it home  [ 2 miles ] when i bought it last week, it has not been driven on the road since, but thanks for your concern, had a look underneath the brake pedal today and found out why the brake lights are on all the time, it is the small plate the switches are attached to, the bottom pop rivet has sheared off and it swivels on the top one, will have to remove brake pedal tomorrow and have a good look at the offending part, will keep you all updated on my progress  

  • Like 1
Link to comment
Share on other sites

Just had a bit of a feel under the pedal and the top rivet has also snapped, and i promise you i did not pull or twist it, just lifted it back into its original position, I now have the bracket in my hand that has two electrical connectors and the other bit it was riveted too that has one electrical fitting, the hole where it was pop riveted is 1.5 mm surely this can't be standard fittings, can anyone get a photo of there 2.5 manual brake pedal looking from underneath, just to see if mine has been tampered with as all the pictures i have seen on the net are for autos or left hand drive and look nothing like mine, any help would be great and help in the fixing of this problem [ and i get Karl as my first name not John, thanks mam he he he]  

Link to comment
Share on other sites

Well didn't get a great deal done today because of the weather, but i did try a few things, first i started the car reversed it out of the garage in between the heavy rain showers, Let it warm up then released the hand brake, as i live on a slight gradient, but the car just stood still, all 4 brakes were slightly binding, and, as usual when i put my foot under the pedal and pulled it up, the car slowly started to move forward. Now i have read about the spring in the servo becoming week and the air pressure over rides the spring pressure, hence applying the brakes, so to check that it is not the servo, i put a couple of wood chocks about 6 inches in front of the wheels and removed the vacuum pipe from the servo with the engine running, the air was released and ------ nothing happened. So i know it is not the air pressure in the servo that is giving me the problem, i even pressed the brake a few times just in case there was any air somewhere in the servo that had not escaped, but no movement of the car, until i again pulled up on the pedal. Well thats one thing eliminated from my long list of possible causes, just bought a Master cylinder today , going to fit this tomorrow, will update with results in the next exiting episode of "The brakes from hell "    

  • Like 1
Link to comment
Share on other sites

Ok Today's episode of [ The brakes from hell ] . Started the car up from cold and reversed it out of the garage. For some unknown reason the brakes were relatively free, but it didn't fool me one bit. I took it up and down the street 3 times and the brakes started to bind again, perfect i thought for my next test. Once again pulled up on the slight incline, stopped the car put the hand brake on and switched off the car,  got out and placed the wood chocks 6 inches away from the front wheels, got back in the car and released the hand brake, the car never moved, so i knew the brakes were binding. I lifted the bonnet and decided to loosen the brake master cylinder from the servo, to do this i first removed the coolant tank, this consisted of a 10mm bolt located at the front of the tank, then i pulled the tank towards me, as there is a plastic part of the coolant tank that fits into a bracket, sort of a locating lug. once it was free, i just pulled it slightly to one side as to allow access to the two 13 mm nuts that hold the master cylinder in place, I slowly started to remove the nuts a bit at a time , alternating from one side to the other, after about two turns on each nut the car started to move forward, the more i slackened the nuts the freer the brakes became, until about 4 full turns on each nut the brakes were off totally, I have concluded that the master cylinder was indeed sticking, but just to eliminate another possibility, when the master cylinder was removed, which entailed the removal of the pipe from the clutch, the electrical connection and the two brake pipes, i tried the pedal to make sure none of the linkage was sticking, as the master cylinder is after all on the passenger side, this was found to be free and in good working order. I then proceeded to replace the master cylinder with another unit, the fitment was the opposite of removal, not forgetting to use a new rubber o ring on the back of the unit before installing the master cylinder onto the servo, that is as far as i have gotten today, as i can't bleed the brakes myself, will keep you updated on the next installment of  [ The brakes from hell ] 

Link to comment
Share on other sites

Finally got around to bleeding the brakes today, took about an hour,I then took the car out for a small drive and the brakes are still binding on, I was gutted, but onward and forward, next job is to replace the servo unit, might have a spare full braking system when I'm finished, he he, these are defo the brakes from hell, lucky i have another car to drive about in

Link to comment
Share on other sites


Hi John, I only joined yesterday and have only just read this post. Why did everyone assume master cylinder? The only way it could be would be if it was actually seized. Surely releasing one bleed nipple and if the pedal goes down then it's not seized. Personally the first thing I would do would be to remove master cyl cap and in turn remove/loosen callipers to check the pistons do retract. If the car has been laid up for some time they can seize, even slightly. With all the computerised stuff on cars these days I'm totally lost but there hasn't been much change in the actual braking system basics.

Well that's my 5 'penneth

Good luck

Dave

Link to comment
Share on other sites

Hi John,

I didn't spot this thread for some reason.

Can I suggest that the problem might lie in the threaded connecting rod from the servo to the brake pedal?

This is held on with a plastic nut and there is also a small plastic shim as well.

What sometimes happens is that the brake pedal is pushed down the servo rod effectively locking the brakes on.

Ie. when you release the brake pedal, the servo rod stays in the brakes applied position.

Removing the nut and shim and checking for wear or damage is simple enough, if you can get in there ;)

Pulling the pedal up firmly will pull the rod cback through the pedal but it will, unfortunately, go back to the same position as soon as you press the brake pedal.

Link to comment
Share on other sites

On the first one, it is possible according to information i have read , that when bleeding the brakes, some crap will get into the master cylinder as it moves past the normal peramiters and gets jammed on the crap it has disloged, that was the thinking behind the master cylinder change, The rod when i removed the cylinder was looked at, and i tried to loosen the adjusting nut but it was solid and so i assume if i cant move it with spanners it wont move by itself, unles you guys know better. Didn't think there was much interest in the subject as didn't get much responce. Going on holiday very soon so it will be left until i get back, but will update when i start working on it again, thanks for your interest and imput, much appreciated. And the reason i suspect the servo is , when you start the car up in the morning the brakes are free, but after a few mins and a few presses on the pedal, they start to bind on, the longer you drive the more they bind, but, if you stand the car on a slight gradiant and put chocks in front of the wheels allowing 6 inches to roll before contacting them, then remove the servo pipe, which allows the presure in the servo to escape, the car moves forward as if the brakes have been released, so thats my next port of call 

Link to comment
Share on other sites

when bleeding brakes always start from the furthest wheel from master cylinder.   using a vacum brake bleeder connect the pipe to the nipple then unscrew it partially and then apply the vacum.  when fluid flows through freely lock off nipple. Then working your way to the front, but always check on reservoir with fresh brake fluid.  when all wheels done the pedal should be firm with engine off !    if still spongy then you still have a leak some where.? 

Link to comment
Share on other sites

Hi John ---To re-cap  --You said that-----"I have noticed today that the brake lights are on permanently, and if i hook my foot under the brake pedal and pull it up, not only do the brake lights go out but the brakes release", 

Then again you said----The pedal is very hard to pull up and it only comes up a couple of millimeters, it is also very hard to push down, feels almost solid, all 4 brakes are sticking on until i pull the pedal up, then the brake lights go out and the brakes come off,

Well I still think its the pedal that's the Problem when you fitted the new master cyl did the pedal move free and easy on its full travel.???

Saying all that the other thing is is there any free movement when you apply the pedal before the brakes work it dos'nt sound as though there is --if you disconnect the rod thats from pedal to master cyl are the brakes on or off???

Just trying to help.

Frank

Link to comment
Share on other sites

And i really do appreciate any help that is offered, on the first one, the small mounting bracket that holds the brake light switches, one of the rivets had come slack and finally snapped, causing the brake lights to be on permanantly, the second one, the reason the pedal was hard to pull up was because it was at the top end of its travel and was hitting the stop, and the reason that the pedal was hard to push down is because the brakes were applied almost fully, but when the master cylinder was removed, the pedal and the connecting parts were free and moved very easliy. As i said when i removed the master cylinder, as i slackened the nuts that hold it on to the servo, the brakes were slowly released. But when the brakes were jammed on and i removed the vacuum pipe the brakes came off straight away, There is about 3mm of free play when the car has been staning and engine not running, Never tried disconnecting the rod while the engine is running but i am willing to give it a try.  And that is the suituation we have at the moment, but as i am going on holiday, it can wait until i get back, my son says he will have a go at it when i am away, but there is no rush so i have told him to leave it in the garage until i get back. but i really do appreciate any imput anyone is willing to give and so i thank you again, if this sheds any light on the suituation,  please let me know what you think, weather it is the same or you have changed your opinion on the fault, but i won't be able to answer until i get back, its a very interesing problem and i am quite enjoying trying different things to solve the problem, i am lucky in one sence as my good friend brakes the x type, so parts are very cheep, its time thats difficult to find 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share





×
×
  • Create New...



Forums


News


Membership