AMS

X type rear hatch keeps opening

Recommended Posts

Hi

 

A bit of background first.  A recently bought X Type 2.2 Sport Estate 56 plate.  

The rear glass hatch opens when I open all the doors on the car and then switch on the ignition.  It is really annoying.  I get out close the hatch and all is then ok.  I have found out that if I only open the drivers door, one press on the remote, the glass hatch does not open on it's own.

The hatch can be opened as per normal by pressing the little micro switch when the car has been opened. 

Occasionally the remote will not work when I exit the car.  Then I have to switch the ignition on and off.  The rear hatch then sometimes pops and once closed the car will lock ok.  This latter problem with the remote is as said only occasional.

Any ideas?

Cheers

Tony.

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

My one does it sparadicaly. Usually caused by my sausage fingers just pressing 2 buttons accidentally on the remote. Sometimes when locking the car my sausage thumb turns the headlights on.

  • Haha 1

Share this post


Link to post
Share on other sites

try this little test ?... try opening the car with key only and see what it does regarding opening of the cars doors ? and check rear glass hatch ?  if  it seems to work ok after a few tests, then try your remote and see what happens then !   sometimes it can be due to your car battery, or actuators not working correctly, short in the wiring, bad earth connections, start with simple tests first then it will help narrow the problem. but in some cases you will then have to get a multimeter and do a thorough check of the door opening process, which can take a long time due to the electrics, plus its components that are used for the opening of the car system. or get an auto electrician to carry it out who will be able to locate the problem.   good luck...… dave

  • Like 1

Share this post


Link to post
Share on other sites

I  wonder wether or not it is a problem with the control modual as mine was replaced with a saloon version instead of estate and now i can not open the glass hatch even using the key or remote also rear wiper no longer works, have been told that estate version of modual is no longer made. I hope that is not the problem as the modual costs £275 + vat and fitting.

Good luck   Alan

Share this post


Link to post
Share on other sites

Hi Alan,

My son who has a very similar car to you, but a bit holder and had a somewhat similar problem, but in reverse, as you might say.

The glass hatch would not lock, and when my mechanic came to do the Service and MOT a few weeks ago he said that it was the control module that was faulty, and the options were to spend £300 on a new one or "fix" the old one so that the glass half of the floor would not open, but the whole rear door would open and close as one unit.

My son went for the fix.

Regards,

Peter.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...